Luna Cloud HSM Disruption - EU Region

Incident Report for Thales Data Protection on Demand

Resolved

The incident has been resolved. Impacted Cloud HSM Services in the EU region are operational.
Posted Mar 26, 2025 - 21:00 UTC

Update

We are investigating a disruption to Luna Cloud HSM services in the EU region impacting crypto transactions.
Posted Mar 26, 2025 - 20:51 UTC

Investigating

Our monitoring has detected a potential issue with Data Protection on Demand Services that may impact customers.

Our team is already investigating and we will update you as soon as we have further news.
Posted Mar 26, 2025 - 20:48 UTC
This incident affected: Luna Cloud HSM (Luna Cloud HSM Services (EU Region)).