Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 04, 2025 - 07:00 UTC
Scheduled
Thales Data Protection on Demand Platform will be performing scheduled maintenance, impacting the management portal in the NA Region.
Service Impact: You can expect management portal functionality to be disrupted for a brief period during the maintenance window. There will also be a brief disruption to the provisioning of new services and tenants during the window.
Maintenance Schedule:
Region: North America Date: Sunday May 4, 2025 Time: 07:00 to 08:00 AM UTC
The maintenance dates are subject to change. We will notify customers of any schedule changes and when the maintenance window is complete. Please contact https://supportportal.thalesgroup.com/csm if you have any questions.
Posted Apr 17, 2025 - 17:48 UTC
This scheduled maintenance affected: DPoD Platform (Management Console (NA Region), Platform APIs (NA Region)).