Incident Update
Incident Report for Thales Data Protection on Demand
Resolved
The disruption to Data Protection on Demand has been investigated and resolved.

Where necessary, corrective action has been taken for affected customers.

If you are experiencing any service issues, please contact https://supportportal.thalesgroup.com/csm
Posted May 10, 2021 - 16:41 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 10, 2021 - 16:23 UTC
Update
We have identified an issue with the creation of new Azure Key Broker Services. Our team has identified a solution and is working on a fix.
Posted May 07, 2021 - 15:20 UTC
Identified
We have identified an issue with the creation of new Azure Key Broker Services. Our team has identified a solution and is working on a fix.
Posted May 07, 2021 - 15:08 UTC
This incident affected: North America Region (CipherTrust Key Management Services (NA Region)) and EU Region (CipherTrust Key Management Services (EU Region)).