Luna Cloud HSM EU Service Disruption
Incident Report for Thales Data Protection on Demand
Postmortem

A post mortem has been conducted for the incident that occurred April 18 impacting Luna Cloud HSM users in the EU region.

A Service Incident Report is available which contains the timeline of events, root cause and planned remediation actions. Users may request a copy of the Service Incident Report via the Thales Customer Support Portal.

Posted Apr 23, 2024 - 18:11 UTC

Resolved
The disruption to Luna Cloud HSM services has been investigated and resolved.

If you are experiencing any service issues, please contact https://supportportal.thalesgroup.com/csm
Posted Apr 18, 2024 - 11:17 UTC
Monitoring
A fix has been implemented and we are monitoring the results.

If you are experiencing any service issues, please contact https://supportportal.thalesgroup.com/csm
Posted Apr 18, 2024 - 11:02 UTC
Investigating
Our monitoring has detected a potential issue with Data Protection on Demand Services that may impact customers.

Our team is already investigating and we will update you as soon as we have further news.
Posted Apr 18, 2024 - 10:45 UTC