Tenant and Service creation

Incident Report for Thales Data Protection on Demand

Resolved

The incident has been resolved.
Posted Mar 02, 2025 - 23:28 UTC

Identified

We have identified an issue with new service creation and new tenant on-boarding in the EU and NA region. We are currently working on a fix.
Posted Mar 02, 2025 - 21:55 UTC

Investigating

Our monitoring has detected a potential issue with Data Protection on Demand Services that may impact customers.

Our team is already investigating and we will update you as soon as we have further news.
Posted Mar 02, 2025 - 21:38 UTC