Potential Disruption

Incident Report for Thales Data Protection on Demand

Resolved

This alert was raised due to some test failures on an inactive site. There was no impact to any user HSM traffic as a result.
Posted 12 days ago. Mar 19, 2025 - 14:36 UTC

Investigating

Our monitoring has detected a potential issue with Data Protection on Demand Services that may impact customers.

Our team is already investigating and we will update you as soon as we have further news.
Posted 12 days ago. Mar 19, 2025 - 09:30 UTC