Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 10, 2025 - 13:00 UTC
Scheduled
Data Protection on Demand (DPoD) will be performing scheduled maintenance to make infrastructure improvements to back office systems.
During the maintenance window the following services will be unavailable: - Creation of new tenants - Provisioning new services - Creation of new subscriptions - Viewing subscription details and pricing
Maintenance Schedule: Region: All Regions Date: May 10, 2025 Time: 13:00 - 14:00 UTC
The maintenance dates are subject to change. We will notify customers of any schedule changes and when the maintenance window is complete. Please contact https://supportportal.thalesgroup.com/csm if you have any questions.
Posted May 01, 2025 - 15:45 UTC
This scheduled maintenance affected: DPoD Platform (Management Console (EU Region), Management Console (NA Region), Platform APIs (EU Region), Platform APIs (NA Region)).