Delayed Loading of Service Tiles in DPoD Marketplace

Incident Report for Thales Data Protection on Demand

Resolved

This incident has been resolved.
Posted Sep 23, 2025 - 16:05 UTC

Identified

We are aware of an issue that is impacting the display service tiles in the DPoD Marketplace. Service tiles will be displayed in the browser after a delay of 2 minutes. This could impact users when deploying a new service instance. There is no impact to any already deployed services.
Posted Sep 23, 2025 - 14:35 UTC
This incident affected: DPoD Platform (Management Console (EU Region), Management Console (NA Region)).