Potential Disruption

Incident Report for Thales Data Protection on Demand

Resolved

This incident has been resolved.
Posted May 07, 2025 - 10:19 UTC

Investigating

Our monitoring has detected a potential issue with Data Protection on Demand Services that may impact customers.

Our team is already investigating and we will update you as soon as we have further news.
Posted May 07, 2025 - 07:08 UTC