The activity is still in progress. We are extending the maintenance window by another 1 hour. We appreciate your patience as we continue working on it.
Posted Jun 30, 2026 - 16:18 UTC
Update
The activity is taking longer than expected. We are extending the maintenance window by 1 hour and are actively working on it.
Posted Jun 30, 2026 - 15:20 UTC
Verifying
Verification is currently underway for the maintenance items.
Posted Jun 30, 2026 - 15:04 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 30, 2026 - 14:30 UTC
Scheduled
We will be undergoing scheduled maintenance during this time.
Posted Jun 30, 2026 - 03:44 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 30, 2026 - 02:30 UTC
Scheduled
CipherTrust Data Security Platform as a Service will be performing scheduled maintenance, impacting the creation of new tenant accounts in both the Europe and North America regions.
Service Impact: We will be performing scheduled maintenance which may cause a temporary interruption to the creation of new CDSPaaS tenant accounts.
Maintenance Schedule:
Region: All Regions Date: Tuesday June 30th 2026 Time: 2:30 PM UTC to 03:10 PM UTC
The maintenance dates are subject to change. We will notify customers of any schedule changes and when the maintenance window is complete. Please contact https://supportportal.thalesgroup.com/csm if you have any questions.
Posted Jun 23, 2026 - 05:00 UTC
This scheduled maintenance affected: CipherTrust Data Security Platform (CipherTrust Data Security Platform (NA Region), CipherTrust Data Security Platform (EU Region)).