Potential Disruption - CipherTrust Data Security Platform
Incident Report for Thales Data Protection on Demand
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 11:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 18, 2024 - 10:56 UTC
Investigating
Our monitoring has detected a potential issue with CipherTrust Data Security Platform Services that may impact customers in EU region. This could be due to an ongoing potential issue on DPoD Platform.

Our team is investigating the issue and will share an update soon.
Posted Apr 18, 2024 - 10:54 UTC
This incident affected: CipherTrust Data Security Platform (CipherTrust Data Security Platform (EU Region)).