Potential Disruption - CipherTrust Data Security Platform

Incident Report for Thales Data Protection on Demand

Resolved

This incident has been resolved.
Posted 7 days ago. Mar 31, 2025 - 07:36 UTC

Update

We are continuing to monitor for any further issues.
Posted 7 days ago. Mar 31, 2025 - 07:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 7 days ago. Mar 31, 2025 - 07:24 UTC

Identified

Our monitoring has detected a potential issue with CipherTrust Data Security Platform Services that may impact CDSP tenant provisioning and deprovisioning operations in EU and NA region.

Our team is investigating the issue and will share an update soon.
Posted 7 days ago. Mar 31, 2025 - 07:05 UTC
This incident affected: CipherTrust Data Security Platform (CipherTrust Data Security Platform (NA Region), CipherTrust Data Security Platform (EU Region)).