User Creation - Data Protection on Demand Platform

Incident Report for Thales Data Protection on Demand

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 19:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 27, 2026 - 19:21 UTC

Identified

The issue has been identified as a problem with new user and new credential creation. This may impact the following operations on the platform;

- Creation of new users
- Creation of new tenant accounts, including new account registration
- Creation of new Platform API credentials
- Creation of new Luna Cloud HSM Client credentials

Our teams are continuing to work on resolving the issue and we will provide further updates when available.
Posted Apr 27, 2026 - 17:55 UTC

Investigating

Our monitoring has detected a potential issue with Data Protection on Demand Services that may impact customers.

Our team is already investigating and we will update you as soon as we have further news.
Posted Apr 27, 2026 - 17:32 UTC
This incident affected: DPoD Platform (Management Console (EU Region), Management Console (NA Region)).