Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 10, 2025 - 07:00 UTC
Scheduled
Thales Data Protection on Demand will be performing scheduled maintenance, impacting the management portal in the North America Region: thales.na.market.dpondemand.io.
Service Impact: You can expect management portal functionality to be unavailable during the maintenance window. This includes new service provisioning, audit log query, user management, tenant management and subscription management.
Maintenance Schedule:
Region: North America Date: August 10, 2025 Time: 07:00 to 08:00 UTC
The maintenance dates are subject to change. We will notify customers of any schedule changes and when the maintenance window is complete. Please contact https://supportportal.thalesgroup.com/csm if you have any questions.
Posted Jul 31, 2025 - 15:47 UTC
This scheduled maintenance affected: DPoD Platform (Management Console (NA Region), Platform APIs (NA Region)).