Disruption - CipherTrust Data Security Platform

Incident Report for Thales Data Protection on Demand

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 19:22 UTC

Investigating

Our monitoring has detected an issue with CipherTrust Data Security Platform Services that may impact customers in EU and NA region.

Provisioning and Deprovisioning is not working in both EU and NA regions.

Existing Services in EU region are experiencing issues.

Our team is investigating the issue and will share an update soon.
Posted Jun 12, 2025 - 18:51 UTC
This incident affected: CipherTrust Data Security Platform (CipherTrust Data Security Platform (NA Region), CipherTrust Data Security Platform (EU Region)).