Luna Cloud HSM Disruption - North America Region

Incident Report for Thales Data Protection on Demand

Postmortem

An SIR report is available for this incident. Customers may request a copy via the Thales support portal

http://supportportal.thalesgroup.com/csm/

Posted May 15, 2026 - 18:05 UTC

Resolved

Luna Cloud HSM services in the North America region experienced a service disruption on Sunday May 10 at approximately 00:30 UTC.

Luna Cloud HSM users may have noticed a reduction in transaction rate, or in some cases a loss of connectivity. The service was restored by failing traffic to the alternate site in the region.

A Service Incident Report (SIR) will be made available once our internal investigation is completed.
Posted May 10, 2026 - 04:30 UTC