On-boarding Disruption

Incident Report for Thales Data Protection on Demand

Resolved

Incident resolved
Posted Aug 24, 2025 - 22:59 UTC

Identified

We have identified an issue with a third party service that is preventing the creation of new tenant accounts. All other services are operation normally.
Posted Aug 24, 2025 - 22:55 UTC

Investigating

Our monitoring has detected a potential issue with Data Protection on Demand Services that may impact customers.

Our team is already investigating and we will update you as soon as we have further news.
Posted Aug 24, 2025 - 22:46 UTC
This incident affected: DPoD Platform (Management Console (EU Region), Management Console (NA Region)).