Potential Disruption

Incident Report for Thales Data Protection on Demand

Resolved

The disruption to CipherTrust Data Security Platform has been investigated and resolved.

If you are experiencing any service issues, please contact https://supportportal.thalesgroup.com/csm
Posted Mar 31, 2025 - 08:10 UTC

Monitoring

A fix has been implemented and we are monitoring the results.

If you are experiencing any service issues, please contact https://supportportal.thalesgroup.com/csm
Posted Mar 31, 2025 - 07:23 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 31, 2025 - 06:57 UTC

Identified

An authentication issue has been identified and teams are working to resolve.
Posted Mar 31, 2025 - 06:52 UTC

Investigating

Our monitoring has detected a potential issue with Data Protection on Demand Services that may impact customers.

Our team is already investigating and we will update you as soon as we have further news.
Posted Mar 31, 2025 - 06:38 UTC
This incident affected: DPoD Platform (Management Console (EU Region), Management Console (NA Region), CipherTrust Key Management Services (EU Region), CipherTrust Key Management Services (NA Region), Platform APIs (EU Region), Platform APIs (NA Region)) and Luna Cloud HSM (Luna Cloud HSM Services (EU Region), Luna Cloud HSM Services (NA Region)).