Data Protection on Demand Platform Disruption

Incident Report for Thales Data Protection on Demand

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 20:34 UTC

Identified

Most platform functionality is recovered.

At this time however audit log queries are not yet operational.
Posted Jun 12, 2025 - 20:02 UTC

Investigating

We are aware of several issues impacting the Data Protection on Demand Platform that may impact customers.

Our team is already investigating and we will update you as soon as we have further news.
Posted Jun 12, 2025 - 19:09 UTC
This incident affected: DPoD Platform (Management Console (EU Region), Management Console (NA Region), Platform APIs (EU Region), Platform APIs (NA Region)).