Potential Disruption - CipherTrust Data Security Platform
Incident Report for Thales Data Protection on Demand
Resolved
This incident has been resolved.
Posted Jul 21, 2024 - 02:02 UTC
Investigating
Our monitoring has detected a potential issue with CipherTrust Data Security Platform Services that may impact customers in EU and NA region. This impacts provisioning and deprovisioning of CDSP tenants.

Our team is investigating the issue and will share an update soon.
Posted Jul 20, 2024 - 22:18 UTC
This incident affected: CipherTrust Data Security Platform (CipherTrust Data Security Platform (NA Region), CipherTrust Data Security Platform (EU Region)).