Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 27, 2026 - 21:00 UTC
Scheduled
Data Protection on Demand will be performing scheduled maintenance impacting user login on welcome.dpondemand.io.
Service Impact: There will be brief periods during the maintenance activity when user login to the management console at welcome.dpondemand.io will be unavailable.
This maintenance does not impact client authentication and there will be no disruption to any services including Luna Cloud HSM Services, CipherTrust Data Security Platform Services and payShield Cloud Services.
Maintenance Schedule:
Date: Monday, April 27, 2026 Time: 21:00 to April 28 01:00 UTC
The maintenance dates are subject to change. We will notify customers of any schedule changes and when the maintenance window is complete. Please contact https://supportportal.thalesgroup.com/csm if you have any questions.
Posted Apr 21, 2026 - 20:34 UTC
This scheduled maintenance affected: DPoD Platform (Management Console (EU Region), Management Console (NA Region)).