Cloud HSM Service Creation issue in EU Region

Incident Report for Thales Data Protection on Demand

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 19:14 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2026 - 19:11 UTC

Update

The issue impacts provisioning of new Ciphertrust Key Management Services and all types of Luna Cloud HSM services.
Posted Mar 13, 2026 - 19:05 UTC

Investigating

We are currently investigating an issue with Cloud HSM service creation in the EU Region.
Posted Mar 13, 2026 - 19:00 UTC
This incident affected: Luna Cloud HSM (Luna Cloud HSM Services (EU Region)) and CipherTrust Data Security Platform (CipherTrust Data Security Platform (EU Region)).